False Positive SpamHaus Listing

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 12:19 UTC

Update

We are continuing to investigate this issue.
Posted Sep 25, 2025 - 11:27 UTC

Investigating

Some users are reporting soft bounces due to a false positive SpamHaus listing.

SMTP2GO has confirmed with SpamHaus this is a false positive and the listing has been removed. See more here: https://www.spamhaus.org/query/ip/158.120.85.125

Please reach out to our support team if you believe you've been impacted
Posted Sep 25, 2025 - 09:26 UTC
This incident affected: Email sending (SMTP service).