Display Issue of Processed Emails

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Aug 09, 2025 - 00:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 08, 2025 - 22:41 UTC

Investigating

We are currently experiencing an issue where some emails are incorrectly shown as “Processed” in the activity feed, even though they have been successfully delivered. This is a display-only issue and does not impact actual email delivery. Our development team has been informed.
Posted Aug 08, 2025 - 13:29 UTC
This incident affected: Member Dashboard.