Potential Downtime: Inbound Server
Incident Report for SMTP2GO
Resolved
Our development team has resolved the issue with our inbound server. Please reach out to support at [email protected] if you're experiencing any problems.
Posted May 29, 2020 - 17:25 UTC
Investigating
Our development team is currently investigating this issue.
Posted May 29, 2020 - 16:19 UTC
This incident affected: Email sending (SMTP service) and API Servers.