Dashboard Down
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Jul 23, 2021 - 16:31 UTC
Update
We are continuing to investigate this issue.
Posted Jul 23, 2021 - 16:30 UTC
Update
We are continuing to investigate this issue.
Posted Jul 23, 2021 - 14:57 UTC
Investigating
You may experience issues accessing certain sections of your SMTP2GO dashboard. As far as we are aware, this has not affected sending. If you need any assistance, contact [email protected].
Posted Jul 23, 2021 - 14:40 UTC
This incident affected: Member Dashboard.