Issues sending to Gmail
Incident Report for SMTP2GO
Resolved
Email to Gmail is now being delivered. Some previously bounced email to Gmail may need to be resent.
Posted Dec 15, 2020 - 01:32 UTC
Investigating
Some email to Gmail is currently failing following the global outage of Google services.
Posted Dec 15, 2020 - 00:05 UTC
This incident affected: Email sending (SMTP service).