Delays sending to Microsoft-hosted domains

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 03:08 UTC

Monitoring

We are currently aware of a global issue affecting emails sent to Microsoft-hosted domains (such as hotmail.com, outlook.com, live.com, etc.). Emails affected will show as "Processed" on the "Reports > Activity" page, and delivery attempts encounter "451 4.7.650……….." responses. This is a Microsoft-wide issue affecting multiple SMTP providers/ESPs, and we are monitoring it closely as they actively work on a fix. Thanks for your patience.
Posted Feb 26, 2026 - 03:01 UTC
This incident affected: Email sending (SMTP service) and API Servers.