Emails held as "Processed"

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 08:45 UTC

Monitoring

A fix has been implemented, and the mail queues are clearing. We are continuing to monitor and if you encounter any further emails being held as "Processed", please contact our support team for assistance.
Posted Feb 20, 2025 - 08:36 UTC

Identified

Our development team has identified the issue, and changes are being applied. The remaining queued emails will be finalized for delivery.
Posted Feb 20, 2025 - 07:50 UTC

Investigating

We are currently investigating an issue where a small number of customers are experiencing emails being held as "Processed". We'll update this incident further once more information is available and we appreciate your patience while this is being resolved.
Posted Feb 20, 2025 - 06:33 UTC
This incident affected: Email sending (SMTP service).