Delivery Delays
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Aug 14, 2024 - 07:29 UTC
Monitoring
We are in ongoing contact with Arelion and they have assured us that they are working to resolve the issue. We will continue to monitor.
Posted Aug 14, 2024 - 07:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 14, 2024 - 06:19 UTC
Investigating
We are currently investigating upstream network slowness with urgency. Some customers may be experiencing emails held as "Processed".
Posted Aug 14, 2024 - 05:54 UTC
This incident affected: Email sending (SMTP service).