O365 Delivery
Incident Report for SMTP2GO
Update
We are getting reports back from MS that show delivery is improving on a per IP basis. The full effect should be felt over the next 14 hours. In the meantime we recommend allowlisting our IP addresses. Below is a KB listing all the outbound ranges. If you have a dedicated IP, you will only need to allow list that one IP address.
https://support.smtp2go.com/hc/en-gb/articles/227835308-Worldwide-Server-Locations-IP-Addresses-and-Email-Routing
Posted Nov 20, 2024 - 23:08 UTC
Identified
We are aware of an issue with 0365 email delivery and are working with Microsoft to resolve it. Email will be delayed during this time. We apologize for any inconvenience caused.
Posted Nov 20, 2024 - 03:30 UTC
This incident affects: Email sending (SMTP service).