Barracuda Outage

Incident Report for SMTP2GO

Resolved

Barracuda has resolved the greylisting issues. Please allow some time for the backlog to clear.
Posted Jul 16, 2025 - 15:01 UTC

Investigating

Barracuda is currently undergoing some unexpected downtime. Please check their status page at https://status.barracuda.com or reach out directly to their support team for further assistance. This issue is unrelated to SMTP2GO.
Posted Jul 16, 2025 - 14:09 UTC
This incident affected: Email sending (SMTP service).