Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2025 - 07:00 UTC
Scheduled
Our Chicago/IL DC is undergoing a scheduled network software upgrade for up to an hour. We are mitigating impact by temporarily moving affected customers to a different server. Some Australian customers will have their server location optimized by moving to our AU data center.
To make sure we can continue accepting email during this time, please make sure you are using "mail.smtp2go.com" as your SMTP mail server, any variations will be offline during maintenance.
If you connect with any of the following IP addresses: 43.228.184.6 or 103.47.204.4 please update your system to connect to one of the following instead: 45.33.53.153 or 66.228.43.14
Posted Sep 09, 2025 - 00:47 UTC
This scheduled maintenance affected: Email sending (SMTP service).