Delivery Delays
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Aug 01, 2024 - 22:24 UTC
Monitoring
The mail queue is clearing and we're continuing to monitor.
Posted Aug 01, 2024 - 21:48 UTC
Identified
The issue has been identified and a fix is being put into place.
Posted Aug 01, 2024 - 21:06 UTC
Investigating
We are investigating degraded performance on one mail server. Some users may experience delays during this time.
Posted Aug 01, 2024 - 19:43 UTC
This incident affected: Email sending (SMTP service).