Display Issue of Processed Emails

Incident Report for SMTP2GO

Resolved

The backlog of delivery status updates has completed.
Posted Jun 14, 2025 - 02:08 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 13, 2025 - 22:40 UTC

Investigating

There appears to be a display issue that has been reported to our developers. Some customers are seeing emails stuck in processed, when emails have been delivered.
Posted Jun 13, 2025 - 13:33 UTC
This incident affected: Member Dashboard.