Some emails delayed on one server
Incident Report for SMTP2GO
Resolved
Emails are flowing again and the remaining emails in the queue will be delivered shortly.
Posted Jan 20, 2022 - 19:45 UTC
Investigating
We've identified one outbound server with an elevated mail queue and are working on identifying and fixing the cause asap.
Posted Jan 20, 2022 - 16:30 UTC
This incident affected: Email sending (SMTP service).