Connection timeouts
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Aug 21, 2024 - 11:05 UTC
Update
We are managing a suboptimal internet connection at one data center location in Chicago, and re-routing traffic to bypass the affected area. Due to continued problems with this internet provider over the last 2 weeks, we are switching this location to a new provider and adding redundancy under urgency, and anticipate this switch to be made within 24 hours. Current connectivity issues will be mitigated within the next few hours.
Posted Aug 21, 2024 - 03:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2024 - 16:20 UTC
Update
This issue may also affect your ability to log into your SMTP2GO account. If that is the case, please try logging in at https://app-eu.smtp2go.com/login/
Posted Aug 20, 2024 - 15:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 20, 2024 - 13:55 UTC
Update
The ISP that serves one of our data centres had an outage. The data centre has been informed and our developers have been rerouting connections to avoid it, but currently there is still a backlog. Hopefully this will be resolved shortly and intermittent connection errors will cease.

In terms of future actions to avoid this, given the recurring problems with this particular ISP, we already have a new ISP lined up to transfer over to.

We are now looking to bring this transfer date forward in light of these further issues.

We will continue to investigate this issue.
Posted Aug 20, 2024 - 11:27 UTC
Investigating
We are currently investigating this issue.
Posted Aug 20, 2024 - 11:24 UTC
Monitoring
Some customers might be experiencing 'connection timeout' errors.

After identifying affected servers and routes, messages on troubled servers have been diverted to unaffected servers and emails have now been forwarded to their intended destination. Any backlogs will be cleared shortly.
Posted Aug 20, 2024 - 10:38 UTC
This incident affected: Email sending (SMTP service).