Login Issues and Possible App Slowness

Incident Report for SMTP2GO

Resolved

This incident has been resolved. If any users are still experiencing issues, please contact support at [email protected].
Posted Sep 17, 2025 - 20:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2025 - 19:52 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 17, 2025 - 19:29 UTC

Investigating

We are currently investigating login issues and possible app slowness. We apologise for any inconvenience encountered due to this.
Posted Sep 17, 2025 - 15:02 UTC
This incident affected: Member Dashboard.