Display Issue of Processed Emails

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 00:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2025 - 10:39 UTC

Update

A fix has been implemented. We are currently monitoring the outcome.
Posted Aug 26, 2025 - 10:37 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2025 - 10:33 UTC

Update

We are continuing to investigate this issue.
Posted Aug 26, 2025 - 09:48 UTC

Investigating

We've noticed an issue with our internal reporting system, resulting in a delay for email events, which can cause emails to appear "processed" even after they've been delivered.
Posted Aug 26, 2025 - 08:59 UTC
This incident affected: Member Dashboard.