Email delivery delay
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted May 30, 2023 - 00:31 UTC
Identified
There appears to be a widespread internet access issue in New Zealand. Local news sources are reporting this: https://www.nzherald.co.nz/business/banking-apps-some-websites-down-as-internet-glitches-strike-local-sites/
Posted May 29, 2023 - 22:08 UTC
Investigating
We are currently investigating an issue with delayed email delivery.
Posted May 29, 2023 - 21:28 UTC
This incident affected: Email sending (SMTP service).