Investigating database connection issue

Incident Report for SMTP2GO

Resolved

The issue stemmed from restrictive access rights to a core database system. This has been resolved and we can confirm email is now flowing as usual.
Posted Apr 04, 2025 - 00:27 UTC

Investigating

We are urgently investigating a database connection issue.
Posted Apr 04, 2025 - 00:10 UTC
This incident affected: Email sending (SMTP service), API Servers, and SMS Messaging.