Temporary overload
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Sep 22, 2020 - 06:30 UTC
Monitoring
Limited impact with overloading on a server. Issue has now been resolved.
Posted Sep 22, 2020 - 06:30 UTC
This incident affected: Email sending (SMTP service).