Delivery Delays
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Jul 30, 2024 - 22:08 UTC
Investigating
We are currently investigating an inbound server issue. Users may be experiencing delivery delays during this time.
Posted Jul 30, 2024 - 19:34 UTC
This incident affected: Email sending (SMTP service).