Delivery Delays
Incident Report for SMTP2GO
Resolved
A fix has been implemented to resolve this issue and we will continue monitoring traffic flows.
Posted Sep 16, 2024 - 21:31 UTC
Investigating
We are currently investigating an issue with one mail server. Users may experience delivery delays during this time.
Posted Sep 16, 2024 - 19:22 UTC
This incident affected: Email sending (SMTP service).