Delivery reports delayed - AU only
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Jul 11, 2024 - 10:37 UTC
Identified
Our AU Webhook servers are experiencing a delay which is affecting dashboard activity reporting. Email is still sending as expected.
Posted Jul 11, 2024 - 04:54 UTC