Processed Emails
Incident Report for SMTP2GO
Resolved
UPDATE: Affected emails have started flowing normally again and will be delivered shortly.

Further information will be provided as soon as possible.
Posted Jan 05, 2023 - 18:05 UTC
Investigating
Some users may experience delays in delivery.
Posted Jan 05, 2023 - 16:27 UTC
This incident affected: Email sending (SMTP service).