552 - Limit Reached Error
Incident Report for SMTP2GO
Resolved
Our development team has identified and resolved the 552 error. Please contact support at [email protected] if you're still experiencing issues.
Posted Nov 02, 2020 - 16:24 UTC
Investigating
You may experience a limit exhausted error "552 Your monthly email allowance is exhausted" when you are within your sending limit.

Our developers are currently investigating this issue with urgency.
Posted Nov 02, 2020 - 14:23 UTC
This incident affected: Email sending (SMTP service).