Delayed emails AU region (appearing as "Processed")

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 06:15 UTC

Monitoring

A small number of customers based in AU may be experiencing delays (emails held as "Processed"). Our team has identified and taken action to resolve this, with the mail queue clearing now. We're continuing to monitor.
Posted Jul 01, 2025 - 04:05 UTC
This incident affected: Email sending (SMTP service).