Deliverability issues
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Oct 22, 2022 - 21:18 UTC
Investigating
We are investigating an issue where emails sent through some servers are receiving bounces such as:

From Gmail's servers:
"550 5.7.1 [103.2.143.149] Messages missing a valid address in From: header, or having no From: header, are not accepted."

This is not only affecting emails sent to Gmail addresses and some users may experience issues with other recipient mail servers.

If you are experiencing this issue or any possibly related problems, please contact our support at [email protected].
Posted Oct 22, 2022 - 12:04 UTC
This incident affected: Email sending (SMTP service).