User Dashboard Down

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Jun 08, 2023 - 15:32 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 08, 2023 - 14:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2023 - 14:42 UTC

Investigating

Users may be unable to access the user dashboard. We're currently investigating this issue.
Posted Jun 08, 2023 - 14:29 UTC
This incident affected: Member Dashboard.