EU Email Delays

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 00:38 UTC

Identified

We want to inform our customers in the EU that you may experience some email delays and potential connectivity issues. This is due to urgent upgrades being performed by an upstream provider.
We are actively monitoring the situation and working closely with the provider to ensure these upgrades have minimal impact on your service.
We appreciate your patience and understanding as we work to resolve this as quickly as possible.
Posted Jul 06, 2025 - 22:51 UTC
This incident affected: Email sending (SMTP service) and API Servers.