Delay in Processing/Delivery of Emails

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Jul 26, 2026 - 06:00 UTC

Investigating

Our developers are investigating an issue causing delays in email processing. Some users on the affected server may see odd emails stuck in the "Processed" stage on their Activity page, whilst others are being delivered.
Posted Jul 25, 2026 - 19:01 UTC
This incident affected: Email sending (SMTP service).