Processed Emails
Incident Report for SMTP2GO
Resolved
This incident has been resolved. If you're still experiencing delivery delays, please contact support at [email protected].
Posted Dec 14, 2021 - 13:00 UTC
Investigating
A small number of accounts may be experiencing delays with emails showing as 'processed' within the dashboard.

We are aware of the issue and are working to clear the backlog.
Posted Dec 14, 2021 - 09:10 UTC
This incident affected: Email sending (SMTP service).