Greylisting Issues with Microsoft/Yahoo

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 04:36 UTC

Identified

We have identified some greylisting issues with Microsoft/Outlook and Yahoo and are actively working on solutions to mitigate the slowed delivery.
Posted Nov 04, 2025 - 22:15 UTC
This incident affected: Email sending (SMTP service).