Delivery Delays

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Aug 12, 2024 - 08:45 UTC

Monitoring

We are continuing to monitor.
Posted Aug 12, 2024 - 05:30 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 12, 2024 - 03:32 UTC

Investigating

Investigating Arelion's network outage - some US-based customers may experience slower than expected transfer rates.
Posted Aug 12, 2024 - 02:26 UTC
This incident affected: Email sending (SMTP service).