Single outbound node issue
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted May 14, 2021 - 01:55 UTC
Investigating
We are currently investigating an issue on a single outbound sending node. Impact is limited to a small number of customers.
Posted May 14, 2021 - 01:45 UTC
This incident affected: Email sending (SMTP service).