Unscheduled Downtime

Incident Report for SMTP2GO

Resolved

A fix has been implemented. Please contact support at [email protected] if you encounter any further issues with processed email.
Posted Feb 03, 2022 - 19:42 UTC

Investigating

We're investigating one outbound server with an elevated mail queue. Users may experience sending delays or have trouble signing up.
Posted Feb 03, 2022 - 13:31 UTC
This incident affected: Email sending (SMTP service).