Network Connectivity Issues

Incident Report for SMTP2GO

Resolved

This incident is now resolved. We apologize for any inconvenience encountered. If you experience issues connecting to our servers, please reach out to our support team for further assistance.
Posted Mar 03, 2026 - 00:08 UTC

Monitoring

A fix has been implemented, and we are continuing to monitor.
Posted Mar 02, 2026 - 22:36 UTC

Investigating

We are investigating a system-wide outage. Users may experience connectivity issues. Please try connecting to mail-us.smtp2go.com or mail-eu.smtp2go.com in the meantime.
Posted Mar 02, 2026 - 17:00 UTC
This incident affected: Email sending (SMTP service).