Service speed reduction

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Apr 29, 2022 - 03:17 UTC

Monitoring

We've identified a couple of issues where sending was halted on an outbound server (due to service process error) and slowed on another (due to unexpected overload). We have rebalanced the queues and restarted services. Email is now flowing as expected. We are continuing to monitor.
Posted Apr 29, 2022 - 00:36 UTC

Investigating

We are currently investigating this situation.
Posted Apr 28, 2022 - 23:08 UTC
This incident affected: Email sending (SMTP service).