Inbound Server Issue

Incident Report for SMTP2GO

Resolved

Our development team has resolved the incident. Please allow some time for the backlog to clear.
Posted Apr 15, 2026 - 17:23 UTC

Investigating

Our development team is currently investigating the inbound mail servers, which are experiencing an unusually high volume of traffic. Users may encounter delays in message delivery while we work to identify the root cause and restore normal performance.
Posted Apr 15, 2026 - 16:26 UTC
This incident affected: Email sending (SMTP service).