Possible Delivery Delays in Europe
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Aug 06, 2024 - 10:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 06, 2024 - 09:57 UTC
Update
We are continuing to investigate this issue.
Posted Aug 06, 2024 - 09:56 UTC
Investigating
We are investigating degraded performance on one mail server. Some Europe-based users may experience delays during this time.
Posted Aug 06, 2024 - 09:20 UTC
This incident affected: Email sending (SMTP service).