Login Page Loading Issues

Incident Report for SMTP2GO

Resolved

This issue was caused by network instability at Akamai/Linode datacenters in the EU. This has now been resolved as per their bulletin on the issue.
Posted Jan 21, 2026 - 03:57 UTC

Update

We are continuing to investigate this issue. If you cannot log in, please try using: https://app-us.smtp2go.com/login/
Posted Jan 20, 2026 - 16:08 UTC

Investigating

Some customers are experiencing issues loading the SMTP2GO login page. Please try logging in at https://app-us.smtp2go.com/login/ while we investigate this issue
Posted Jan 20, 2026 - 15:27 UTC
This incident affected: SMTP2GO Website.