Delivery Delays

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 07:28 UTC

Update

The remaining mail queues are now clearing, and we are continuing to monitor.
Posted Jul 16, 2025 - 06:46 UTC

Monitoring

A fix has been implemented, and we are monitoring the results. Thank you for your continued patience.
Posted Jul 16, 2025 - 06:31 UTC

Identified

We've identified the root cause of the email delivery delays. The problem lies with an upstream provider, and steps are actively being taken to resolve this as quickly as possible.
Posted Jul 16, 2025 - 05:56 UTC

Investigating

We're aware of and actively investigating a delivery delay issue affecting a small number of customers. Our team is working diligently to identify the cause and restore normal service without delay.
Posted Jul 16, 2025 - 05:34 UTC
This incident affected: Email sending (SMTP service) and API Servers.