Network Connectivity Issues

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 09:05 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 24, 2025 - 04:42 UTC

Monitoring

A fix has been implemented and we are monitoring results.
Posted Apr 23, 2025 - 22:04 UTC

Investigating

We're currently investigating a networking issue. Users may encounter "451" or "421" errors when attempting to send.
Posted Apr 23, 2025 - 17:59 UTC
This incident affected: Email sending (SMTP service).