Delay in email events showing on the Activity page - AU region

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 12:20 UTC

Monitoring

The backlog of delayed reporting events is now clearing, and we are continuing to monitor the system closely.
Posted Oct 21, 2025 - 03:00 UTC

Identified

We are currently investigating a reporting delay that may affect some users in the AU region.
Please note that email delivery is unaffected and messages are sending successfully. However, emails on your Activity reporting page may be temporarily stuck at the "Processed" status, even though they have already been delivered to the recipient.
Our team is actively working on a fix for this delay in reporting events and is closely monitoring the results.
Posted Oct 21, 2025 - 02:04 UTC
This incident affected: Member Dashboard.