Processed emails (US)
Incident Report for SMTP2GO
Resolved
This incident has now been resolved.
Posted Jul 22, 2024 - 16:49 UTC
Investigating
Some users in the US may see emails stuck in the "Processed" status.

We are currently investigating and hope to have an update soon.
Posted Jul 22, 2024 - 13:26 UTC
This incident affected: Email sending (SMTP service).