Delays in Updating Activity Reports, EU Region Only
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 11:18 UTC
Investigating
A recent upgrade resulted in an issue with updating Activity Reports. Some clients in the EU region may notice delays.
Posted Oct 07, 2024 - 08:47 UTC
This incident affected: Member Dashboard.