Processed Emails
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Jul 30, 2024 - 09:57 UTC
Monitoring
Some users may see emails as "Processed".

The issue has been identified and a fix has been implemented. Newly sent emails will be sent as normal and any emails still in the"Processed" status will be sent as soon as possible.
Posted Jul 30, 2024 - 07:37 UTC
This incident affected: Email sending (SMTP service).