Connectivity Issues and Delivery Delays
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted May 14, 2024 - 16:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 14, 2024 - 15:30 UTC
Identified
One of our internet service providers (Arelion) is reporting a connectivity issue that may impact users' ability to connect to our service as well as delay deliveries. Please stand by for updates.
Posted May 14, 2024 - 14:46 UTC
This incident affected: Email sending (SMTP service) and API Servers.