Processed Emails
Incident Report for SMTP2GO
Resolved
The email backlog has been cleared, and we've upgraded network and DC performance.
Posted Sep 06, 2022 - 20:47 UTC
Investigating
Some of our users may be experiencing minor delays. For assistance, please write to [email protected].
Posted Sep 06, 2022 - 15:42 UTC
This incident affected: Email sending (SMTP service).