Processed Emails

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Nov 18, 2022 - 13:02 UTC

Investigating

Some of you may experience slight delays. We are investigating this with urgency.
Posted Nov 18, 2022 - 12:43 UTC