Activity display issue
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Dec 01, 2023 - 20:46 UTC
Investigating
We are investigating a potential issue that may affect some customer's activity page. Emails get delivered but do not display on the activity page.

We will update this status as information becomes available.
Posted Dec 01, 2023 - 17:18 UTC
This incident affected: Member Dashboard.